summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Bruguera Micó2024-03-10 23:40:50 +0000
committerJoan Bruguera Micó2024-03-10 23:40:50 +0000
commitc8a1d5b6ed88b8fdd85dca292556578e50014c2c (patch)
tree67a7948b3c85dc59e99280e04f521e8fd00c2fe8 /PKGBUILD
parent12a2c2660aef1c0eaa808e35a7aa78e879876e57 (diff)
downloadaur-spectral.tar.gz
Fix build with GCC 14
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a95f9eda8fbd..40542e48f0cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='spectral'
pkgdesc='Signal processing techniques to select representative regions from Paraver traces (from BSC).'
pkgver='3.4.1.20180918'
-pkgrel='2'
+pkgrel='3'
arch=('x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('GPL3')
@@ -21,6 +21,9 @@ prepare() {
build() {
cd "$srcdir/$pkgname-${pkgver%.*}"
+ # For now, ignore new errors from GCC 14 (see https://gcc.gnu.org/gcc-14/porting_to.html)
+ export CFLAGS="$CFLAGS -Wno-error=implicit-function-declaration"
+
./configure \
--prefix=/usr \
--with-fft=/usr \
@@ -34,4 +37,4 @@ package() {
cd "$srcdir/$pkgname-${pkgver%.*}"
make DESTDIR="$pkgdir/" install
-} \ No newline at end of file
+}