aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTBK2020-03-17 15:54:38 +0100
committerTBK2020-03-17 16:04:43 +0100
commite1c0e522c97a2a2e8aaaea17dd2ef631c0bce3ed (patch)
tree950278d5b0709b9cae3eefc5f6821095d8bf95d5 /PKGBUILD
downloadaur-e1c0e522c97a2a2e8aaaea17dd2ef631c0bce3ed.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b43b0bc64a2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: TBK <aur at jjtc dot eu>
+# Contributor: TBK <aur at jjtc dot eu>
+
+pkgname=spectral-matrix
+_pkgname=spectral
+pkgver=817
+pkgrel=1
+_commit_sortfilterproxymodel="36befddf5d57faad990e72c88c5844794f274145"
+pkgdesc='Glossy cross-platform client for Matrix'
+url='https://gitlab.com/spectral-im/spectral'
+arch=('any')
+license=('GPL3')
+conflicts=('spectral-matrix-git')
+depends=('qt5-graphicaleffects' 'qt5-multimedia' 'qt5-quickcontrols2' 'qt5-svg' 'qt5-tools' 'qtkeychain' 'libquotient-git' 'libqtolm-git')
+makedepends=('cmake')
+source=("$pkgname-$pkgver.tar.gz::https://gitlab.com/spectral-im/spectral/-/archive/$pkgver/spectral-$pkgver.tar.gz"
+ "SortFilterProxyModel-$_commit_sortfilterproxymodel.tar.gz::https://github.com/oKcerG/SortFilterProxyModel/archive/$_commit_sortfilterproxymodel.tar.gz")
+sha256sums=('6888ad58282eb5baab83d7037423d22b6c2d5be60f8452168b57b39b53e6ca0d'
+ '1f5a6c64f793e7d74e8922e071392cf33baa4e7457e70f396c1e1fcb9d63b378')
+_builddir="$_pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ rmdir \
+ include/libQuotient \
+ include/SortFilterProxyModel
+ mv ../SortFilterProxyModel-$_commit_sortfilterproxymodel include/SortFilterProxyModel
+}
+
+build() {
+ cd "$_builddir"
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_INTREE_LIBQMC=false \
+ -DGIT_FOUND=false
+ make -C build
+}
+
+package() {
+ cd "$_builddir"
+ make -C build DESTDIR="$pkgdir" install
+}