summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsph2016-02-21 21:59:19 +0000
committersph2016-02-21 21:59:19 +0000
commitf74e378ec71279cbfc5d43f21d75bdd53a237c3d (patch)
treeef7344244805eaa8680447dfe75b8e041eda8139 /PKGBUILD
parent839ce51cd92c8b51911fef8e1079cf2b50b6fc4b (diff)
downloadaur-f74e378ec71279cbfc5d43f21d75bdd53a237c3d.tar.gz
change pkgver creation. checkout stable branch instead of master
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7b08d75bee5..20590b4a1e2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
pkgname=sph-lib-git
-_gitname=sph-lib
-pkgver=a641d33
-pkgrel=3
+pkgver=181
+pkgrel=1
pkgdesc='set of over 80 guile scheme libraries'
arch=(any)
license=(gpl3)
makedepends=(git)
depends=(guile)
provides=(sph-lib)
-source=("git://git.sph.mn/sph-lib")
+source=("$pkgname::git://git.sph.mn/sph-lib#branch=stable")
url="http://sph.mn/content/187"
md5sums=(SKIP)
pkgver() {
- cd $_gitname
- git log -n 1 --pretty=format:"%h"
+ cd $pkgname
+ git rev-list --count HEAD
}
package() {
- cd $_gitname
+ cd $pkgname
chmod 755 -R "${pkgdir}"
./exe/install "${pkgdir}"
} \ No newline at end of file