summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortantalum2019-02-22 13:07:29 +0000
committertantalum2019-02-22 13:07:29 +0000
commit72fc75b4e81c99e2eb0f2d8e6cf9a621ad6ecf79 (patch)
treed612f90761a02808ce20baa56bde34af18c582f8 /PKGBUILD
parente11b9c9a9f6b07901b6fd8cb4e168f48e07e830b (diff)
downloadaur-72fc75b4e81c99e2eb0f2d8e6cf9a621ad6ecf79.tar.gz
update pkgbuild
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8f49085bc88..020dabb9d999 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
-pkgname=sescript-git
-pkgver=45
+pkgname=sph-web-publish-git
+pkgver=30
pkgrel=1
-pkgdesc="scheme-like s-expression language that translates to ecmascript/javascript"
+pkgdesc="static site generator"
arch=(any)
license=(gpl3+)
makedepends=(git)
-depends=(guile sph-lib)
-provides=(sescript)
-conflicts=(sescript)
-source=("git://git.sph.mn/sescript")
+depends=(guile guile-commonmark sph-lib)
+optdepends=(rsync graphicsmagick)
+provides=(sph-web-publish)
+conflicts=(sph-web-publish)
+source=("git://git.sph.mn/sph-web-publish")
url="http://sph.mn"
md5sums=(SKIP)
pkgver() {
- cd $pkgname
+ cd sph-web-publish
git rev-list --count HEAD
}
package() {
- cd $pkgname
- ./exe/install --prefix="${pkgdir}"
+ cd sph-web-publish
+ ./exe/install "${pkgdir}"
} \ No newline at end of file