summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2021-12-03 20:04:05 +0100
committerMartchus2021-12-03 20:04:05 +0100
commite6cf223e390bf675563b80e317f7cd2a14b5a9a1 (patch)
tree2b4d5a5bf375eea990888f22ffa90c59ea966615 /PKGBUILD
parent1afdeed747cddb42f9c73dd4da404ec2227255b6 (diff)
downloadaur-sphinxbase.tar.gz
Rebuild against Python 3.10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74b5926e524b..821fff8c8ff9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
pkgname=sphinxbase
pkgver=5prealpha
-pkgrel=12
+pkgrel=13
pkgdesc='Common library for sphinx speech recognition'
-url='http://cmusphinx.sourceforge.net/'
+url='https://cmusphinx.sourceforge.net/'
arch=('i686' 'x86_64')
license=('BSD')
makedepends=('bison' 'swig')
@@ -22,15 +22,16 @@ options=('!libtool')
prepare() {
cd "${pkgname}-${pkgver}"
- msg2 "Reconfiguring project for current version of Automake"
- autoreconf -ivf > /dev/null
patch -p1 -b -i ../sphinxbase-5prealpha-fix-doxy2swig.patch
+
+ echo "Reconfiguring project for current version of Automake"
+ autoreconf -ivf > /dev/null
}
build() {
cd "${pkgname}-${pkgver}"
- export PYTHON=/usr/bin/python
+ export PYTHON=/usr/bin/python PYTHONWARNINGS=ignore
./configure --prefix=/usr
make
}