summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2021-09-10 17:03:45 +0200
committerMartchus2021-09-10 17:03:45 +0200
commit1afdeed747cddb42f9c73dd4da404ec2227255b6 (patch)
treeb1ae4c441ebd399c2b1a00fb947d7cd598129d9c /PKGBUILD
parent3dff520e6fc4652ccf1479ce5eb148663a4ea46b (diff)
downloadaur-1afdeed747cddb42f9c73dd4da404ec2227255b6.tar.gz
Drop Python 2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 7 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4da2075165e6..74b5926e524b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
-# Maintainer: Marco Pompili <aur AT emarcs DOT org>
+# Maintainer: Martchus <martchus@gmx.net>
+# Contributor: Marco Pompili <aur AT emarcs DOT org>
# Contributor: Giorgio Gilestro crocowhile@gmail.com
-# Contributor: Martchus <martchus@gmx.net>
# Contributor: Mladen Milinkovic <maxrd2@smoothware.net>
pkgname=sphinxbase
pkgver=5prealpha
-pkgrel=11
-pkgdesc='Common library for sphinx speech recognition.'
+pkgrel=12
+pkgdesc='Common library for sphinx speech recognition'
url='http://cmusphinx.sourceforge.net/'
arch=('i686' 'x86_64')
license=('BSD')
makedepends=('bison' 'swig')
-depends=('python2' 'python' 'lapack' 'libpulse') # not sure if libsamplerate is needed 'libsamplerate'
+depends=('python' 'lapack' 'libpulse') # not sure if libsamplerate is needed 'libsamplerate'
source=("http://downloads.sourceforge.net/project/cmusphinx/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
"sphinxbase-5prealpha-fix-doxy2swig.patch")
@@ -25,36 +25,18 @@ prepare() {
msg2 "Reconfiguring project for current version of Automake"
autoreconf -ivf > /dev/null
patch -p1 -b -i ../sphinxbase-5prealpha-fix-doxy2swig.patch
-
- cd ..
-
- cp -R "${pkgname}-${pkgver}" "${pkgname}-${pkgver}-py2"
- cp -R "${pkgname}-${pkgver}" "${pkgname}-${pkgver}-py3"
}
build() {
- cd "${pkgname}-${pkgver}-py2"
-
- msg2 "Building Sphinxbase with Python 2 bindings..."
- export PYTHON=/usr/bin/python2
- ./configure --prefix=/usr
- make
+ cd "${pkgname}-${pkgver}"
- cd "../${pkgname}-${pkgver}-py3"
- msg2 "Building Sphinxbase with Python 3 bindings..."
export PYTHON=/usr/bin/python
./configure --prefix=/usr
make
}
package() {
- cd "${pkgname}-${pkgver}-py2"
-
- msg2 "Installing Sphinxbase with Python 2 bindings"
- make DESTDIR="${pkgdir}/" install
-
- msg2 "Installing Python 3 bindings"
- cd "../${pkgname}-${pkgver}-py3/swig"
+ cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}/" install
install -d "${pkgdir}/usr/share/licenses/${pkgname}"