summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJocelyn Thode2022-05-11 18:40:05 +0200
committerJocelyn Thode2022-05-11 18:40:05 +0200
commit5ac2b3e570151e2dac5f5a24390b8df818422a60 (patch)
tree047d75a911edb53ac40b4a720ed6a7f89efce5ea /PKGBUILD
downloadaur-spicetify-theme-dracula-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe4c3ffce826
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer Jocelyn Thode <jocelyn.thode@gmail.com>
+pkgname=spicetify-theme-dracula-git
+_pkgname=Dracula-Spicetify
+pkgver=r19.g97bf149
+pkgrel=1
+pkgdesc="Dracula theme for Spotify through spicetify-cli"
+arch=('any')
+url="https://github.com/Darkempire78/Dracula-Spicetify"
+license=('custom')
+depends=(spicetify-cli)
+source=("git+https://github.com/Darkempire78/Dracula-Spicetify.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p "${pkgdir}/usr/share/spicetify-cli/Themes/Dracula"
+ cp -r ${srcdir}/${_pkgname}/Dracula/* "${pkgdir}/usr/share/spicetify-cli/Themes/Dracula/"
+}
+