summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGI_Jack2020-02-05 20:53:12 -0500
committerGI_Jack2020-02-05 20:53:12 -0500
commitfe67fff8d55c85b3f9c1256044b46e7bf2394a3a (patch)
tree053e191a2228829ad797fd6528a859cecb93ca28 /PKGBUILD
parentb0af4c6f21000b42e2e5e36216eb04eebf21ed69 (diff)
downloadaur-fe67fff8d55c85b3f9c1256044b46e7bf2394a3a.tar.gz
version 3.0 release. python3 port. YAY
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 19 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03ef55a96f6b..9b0f2bd9cb0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,41 @@
# Maintainer: GI_Jack <GI_Jack@hackermail.com>
pkgname=spiderfoot
-pkgver=2.12.0
-_verpostfix="-final"
+pkgver=3.0
pkgrel=1
pkgdesc="SpiderFoot is an open source intelligence automation tool. Its goal is to automate the process of gathering intelligence about a given target."
arch=('any')
url="http://www.spiderfoot.net/"
license=('GPLv2')
-depends=( 'python2' 'python2-m2crypto' 'python2-netaddr' 'python2-dnspython' 'python2-cherrypy' 'python2-mako' 'python2-pysocks' 'python2-pypdf2' 'python2-stem' 'python2-bs4' 'python2-phonenumbers')
-makedepends=('python2')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/smicallef/spiderfoot/archive/v${pkgver}-final.tar.gz"
+depends=( 'python' 'python-dnspython' 'python-exifread' 'python-cherrypy'
+ 'python-mako' 'python-beautifulsoup4' 'python-lxml' 'python-netaddr'
+ 'python-pysocks' 'python-requests' 'python-ipwhois'
+ 'python-ipaddress' 'python-phonenumbers' 'python-pypdf2'
+ 'python-stem' 'python-whois' 'python-future' 'python-pyopenssl'
+ 'python-docx' 'python-pptx' 'python-networkx' 'python-cryptography'
+ 'python-secure' 'python-pygexf' 'python-adblockparser')
+makedepends=('python')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/smicallef/spiderfoot/archive/v${pkgver}.tar.gz"
"spiderfoot.sh"
- "spiderfoot.service")
-sha256sums=('93946fb8ff8b53fae53187ea5ff7a09da07da0e09c29480d52fe78b0524cbcb7'
+ "spiderfoot.service"
+ "spiderfoot.default")
+sha256sums=('bc8048ead13ab02d24155c9d8426f3ec15efb7adc9ce585de796ea34df1808ad'
'2246fe34cd61433a35cd49f2d6d18a6a66fd714014c6c703d1f1f29e3b2a5007'
- 'fe22ab59b2e6b118c3d7fdeb7da2ca8489379810acae713519a48a651c62774e')
+ '416dfddbc1e0910a939730c645cb385ed05cc7df1c2fdb094e1a696871e0bf61'
+ 'b55ca3ad0243f3678ab0ed700fb0b3c5f901dfb9c364ba4ca12ed36267e3c32c')
build() {
- cd "${pkgname}-${pkgver}${_verpostfix}"
- # Add shebang because derp who wrote this is a windows silly goose
- for file in *.py;do
- sed -i '1s/^/#!\/usr\/bin\/python2\n/' ${file}
- done
- python2 -m compileall *.py
+ cd "${pkgname}-${pkgver}"
+ python -m compileall *.py
}
package() {
- cd "${pkgname}-${pkgver}${_verpostfix}"
+ cd "${pkgname}-${pkgver}"
mkdir -p "${pkgdir}/usr/share/spiderfoot"
- #mkdir -p "${pkgdir}/usr/bin"
cp -r * "${pkgdir}/usr/share/spiderfoot"
install -Dm755 "${srcdir}/spiderfoot.sh" "${pkgdir}/usr/bin/spiderfoot"
install -Dm644 "${srcdir}/spiderfoot.service" "${pkgdir}/usr/lib/systemd/system/spiderfoot.service"
+ install -Dm644 "${srcdir}/spiderfoot.default" "${pkgdir}/etc/default/spiderfoot"
}