summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatt Warner2016-02-04 19:51:44 -0700
committerMatt Warner2016-02-04 19:51:44 -0700
commitdaec240156f50e852cabd79164b7cd70a6c0be62 (patch)
tree5b7e958f0331f3d3e6737f44ff99fa8305e93929 /PKGBUILD
parente40c308a9880d1869bf0c67a51033b71d492c5e7 (diff)
downloadaur-daec240156f50e852cabd79164b7cd70a6c0be62.tar.gz
Update to v6.1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 295cb14ef211..8580dd2cf9c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,30 @@
pkgname=spideroak-one
_PkgName=SpiderOakONE
-pkgver=6.1
+pkgver=6.1.2
pkgrel=1
pkgdesc="Secure file backup, sync and sharing client. This provides the client for SpiderOakONE."
arch=('i686' 'x86_64')
url="https://spideroak.com/"
license=('custom')
-depends=('glibc>=2.9')
-makedepends=('desktop-file-utils')
+depends=('glibc>=2.9' 'desktop-file-utils')
+makedepends=()
provides=('spideroak')
conflicts=('spideroak-beta' 'spideroak')
replaces=('spideroak')
options=('!strip')
install=${pkgname}.install
source=(terms.txt)
-sha256sums=('4819c8d923ab19e552e877b87adf1d45aca6adcb5dffcb238d7819501e6e6737')
-if [ "$CARCH" == x86_64 ]; then
- source+=("spideroakone_${pkgver}_amd64.deb::https://spideroak.com/getbuild?platform=ubuntu&arch=x86_64")
- sha256sums+=('4501c7f76e846acc9d99073e9920fd17a0531fa90ff3da0bcef8ae7239fe9408')
-elif [ "$CARCH" == i686 ]; then
- source+=("spideroakone_${pkgver}_i386.deb::https://spideroak.com/getbuild?platform=ubuntu&arch=i386")
- sha256sums+=('0bb66a2fc60fdc2ceabed2c574d296ae6bd37a17b73d65af948fd2850cd2c4e2')
-fi
+sha256sums=('4adccd220a64a8cd82126458920d227baf502ae605f680c0fdbdad35e89492a4')
+source_x86_64=("spideroakone_${pkgver}_amd64.deb::https://spideroak.com/getbuild?platform=ubuntu&arch=x86_64")
+sha256sums_x86_64=('c13d79099af744e77b9dcd6e72c7fe23f855af28fd16c4bbc762a545139273e7')
+source_i686=("spideroakone_${pkgver}_i386.deb::https://spideroak.com/getbuild?platform=ubuntu&arch=i386")
+sha256sums_i686=('02336a38554b499d60466da6ee2038066036858159cd639384463ae0c865dee7')
package() {
tar -zxvf "${srcdir}"/data.tar.gz -C "$pkgdir"/
+
+install -Dm644 "$srcdir"/terms.txt "$pkgdir"/usr/share/licenses/$pkgname/terms.txt
+
+rm -rfv "$pkgdir"/etc/apt/
} \ No newline at end of file