summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfrederik2015-07-30 17:06:01 +0200
committerfrederik2015-07-30 17:06:01 +0200
commit531464f71ca6669503e6fec0b6550d2d1cbd5b61 (patch)
treee0ccd140515fc9e0445284116cc74a304ec1e677 /PKGBUILD
downloadaur-531464f71ca6669503e6fec0b6550d2d1cbd5b61.tar.gz
inital commit from aur3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe8ad8d45528
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Frederik Schwan <frederik dot schwan at linux dot com>
+# Contributor: Ghost of Kendo <ghostofkendo at gmail dot com>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: Pierre Chapuis <catwell@archlinux.us>
+
+pkgname=spin
+pkgver=6.4.3
+pkgrel=1
+pkgdesc='Tool for the formal verification of distributed software systems.'
+arch=('i686' 'x86_64')
+url='http://spinroot.com/'
+license=('custom:SPIN')
+depends=('glibc')
+source=("http://spinroot.com/spin/Src/src${pkgver//./}.tar.gz"
+ 'LICENSE.txt')
+DLAGENTS='http::/usr/bin/curl -A "Mozilla/4.0" -fLC - --retry 3 --retry-delay 3 -o %o %u'
+md5sums=('8f49cf98fe7bc2ac08f75ad29280843a'
+ '1b7db1b5f5da972bab3db17472e3a342')
+
+build() {
+ cd Src${pkgver}
+
+ make
+}
+
+package() {
+ cd Src${pkgver}
+
+ install -D spin \
+ ${pkgdir}/usr/bin/spin
+
+ install -D -m644 ${srcdir}/LICENSE.txt \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
+}