summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Engestrom2022-06-22 09:24:02 +0100
committerEric Engestrom2022-06-22 09:44:41 +0100
commite4f8eb5f6b6943d822fcc7812e994585877ba311 (patch)
tree7d50e853352b53b862ccd43967ad95c83534c0f8 /PKGBUILD
parent99129360ba95eaff0fb8a0f7760c7337d4cd43ad (diff)
downloadaur-e4f8eb5f6b6943d822fcc7812e994585877ba311.tar.gz
fix pkgver to ignore unwanted non-annotated tags
These were needed in the past because upstream hasn't been very consistent with their tags, but it hasn't been needed in a bit over 2 years now (2019.2 was the last one). Additionally, only consider tags matching `v*.*`, in case upstream adds other random annotated tags again.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 372a0bbd8e8c..e52156eba153 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ conflicts=('spirv-tools')
provides=('spirv-tools')
pkgver() {
- git -C SPIRV-Tools describe --tags --abbrev=10 | sed 's/^v//; s/-/+/; s/-/./'
+ git -C SPIRV-Tools describe --match 'v*.*' --abbrev=10 | sed 's/^v//; s/-/+/; s/-/./'
}
build() {