summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 15:13:38 +0200
committerAlexander F Rødseth2015-06-10 15:13:38 +0200
commitd75d6ab83dff348501810781b7dc90a8e63b2f3b (patch)
treec64476c814f1933dc5faa102458c2defe789f25d /PKGBUILD
downloadaur-spl.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16f38507f655
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+
+pkgname=spl
+pkgver=1.0pre6
+pkgrel=1
+pkgdesc='SPL Programming Language'
+url='http://www.clifford.at/spl/'
+license=('GPL2')
+makedepends=('setconf')
+arch=('x86_64' 'i686')
+source=("http://www.clifford.at/spl/releases/$pkgname-$pkgver.tar.gz")
+sha256sums=('737658aea624f17ede8bb965b89cbd4acf40148906c55d3eebc8cc34d1755c30')
+
+prepare() {
+ setconf "$pkgname-$pkgver/GNUmakefile" prefix /usr
+}
+
+build() {
+ make -C "$pkgname-$pkgver"
+}
+
+package() {
+ make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: