summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesus Alvarez2016-04-21 01:38:28 -0700
committerJesus Alvarez2016-04-21 01:38:28 -0700
commite4b52921fab82856660e607a19af6e30285443f2 (patch)
treeafe3c2adbd627cab95b1618b7937c261dd711817 /PKGBUILD
downloadaur-e4b52921fab82856660e607a19af6e30285443f2.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46ac812d4657
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
+#
+# This PKGBUILD was generated by the archzfs build scripts located at
+#
+# http://github.com/archzfs/archzfs
+#
+# ! WARNING !
+#
+# The archzfs packages are kernel modules, so these PKGBUILDS will only work with the kernel package they target. In this
+# case, the archzfs-linux packages will only work with the default package! To have a single PKGBUILD target many kernels
+# would make for a cluttered PKGBUILD!
+#
+# If you have a custom kernel, you will need to change things in the PKGBUILDS. If you would like to have AUR or archzfs repo
+# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
+# archzfs github page.
+#
+pkgname="spl-linux-git"
+pkgver=0.6.5_r49_g224817e_4.5.1_1
+pkgrel=1
+pkgdesc="Solaris Porting Layer kernel modules."
+depends=("spl-utils-linux-git" "kmod"
+ "linux>=4.5.1" "linux<4.6"
+ "linux-headers>=4.5.1" "linux-headers<4.6")
+arch=("x86_64")
+url="http://zfsonlinux.org/"
+source=("git+https://github.com/zfsonlinux/spl.git")
+sha256sums=("SKIP")
+groups=("archzfs-linux-git")
+license=("GPL")
+install=spl.install
+provides=("spl-linux-git")
+makedepends=("git")
+
+build() {
+ cd "${srcdir}/spl"
+ ./autogen.sh
+ ./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
+ --with-linux=/usr/lib/modules/4.5.1-1-ARCH/build \
+ --with-config=kernel
+ make
+}
+
+package() {
+ cd "${srcdir}/spl"
+ make DESTDIR="${pkgdir}" install
+ mv "${pkgdir}/lib" "${pkgdir}/usr/"
+ # Remove reference to ${srcdir}
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.5.1-1-ARCH/Module.symvers
+}