summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesus Alvarez2018-03-16 20:51:50 -0700
committerJesus Alvarez2018-03-16 20:51:50 -0700
commit7329c5b9427e3d09bd095c77b7c9620a16c8ca21 (patch)
treeb758959fb3ca7a817273e6efaa8ccffd2f23e2ac /PKGBUILD
parentc10dccec87c1ce0391cb78c5fd4109d1e7bcd2bd (diff)
downloadaur-7329c5b9427e3d09bd095c77b7c9620a16c8ca21.tar.gz
Semi-automated update for 4.15.9.a.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7029d0323821..8619627b8b7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,22 +18,22 @@
pkgbase="spl-linux-hardened"
pkgname=("spl-linux-hardened" "spl-linux-hardened-headers")
-pkgver=0.7.6_4.15.8.a.1
+pkgver=0.7.6_4.15.9.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.15.8.a-1" "git")
+makedepends=("linux-hardened-headers=4.15.9.a-1" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/spl-0.7.6.tar.gz")
sha256sums=("648148762969d1ee94290c494c4f022aeacabe0e84cddf65906af608be666f95")
license=("GPL")
-depends=("spl-utils-common=0.7.6" "kmod" "linux-hardened=4.15.8.a-1")
+depends=("spl-utils-common=0.7.6" "kmod" "linux-hardened=4.15.9.a-1")
build() {
cd "${srcdir}/spl-0.7.6"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.15.8-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.15.8-1-hardened/build \
+ --with-linux=/usr/lib/modules/4.15.9-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.15.9-1-hardened/build \
--with-config=kernel
make
}
@@ -53,10 +53,10 @@ package_spl-linux-hardened() {
package_spl-linux-hardened-headers() {
pkgdesc="Solaris Porting Layer kernel headers."
- conflicts=('spl-archiso-linux-headers' 'spl-archiso-linux-git-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-threadripper-headers' 'spl-linux-threadripper-git-headers' 'spl-linux-threadripper-vfio-headers' 'spl-linux-threadripper-vfio-git-headers' 'spl-linux-vfio-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
+ conflicts=('spl-archiso-linux-headers' 'spl-archiso-linux-git-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-vfio-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
cd "${srcdir}/spl-0.7.6"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.15.8-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.15.9-1-hardened/Module.symvers
}