summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesus Alvarez2017-08-13 16:27:03 -0700
committerJesus Alvarez2017-08-13 16:27:03 -0700
commitf81a540cb7f32f5b567fa915596f1c4e853006ce (patch)
tree6b27adcf3a6d7798a2e74216ef1914610d3ca1e9 /PKGBUILD
parent0aee0194150b93d487882959a293d2d7c8bdddf5 (diff)
downloadaur-f81a540cb7f32f5b567fa915596f1c4e853006ce.tar.gz
Semi-automated update for 4.12.7.a.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 160f2a206c82..333aefdcb147 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,22 +17,22 @@
#
pkgbase="spl-linux-hardened"
pkgname=("spl-linux-hardened" "spl-linux-hardened-headers")
-pkgver=0.7.1_4.12.5.a_1
+pkgver=0.7.1_4.12.7.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.12.5.a-1")
+makedepends=("linux-hardened-headers=4.12.7.a-1")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.1/spl-0.7.1.tar.gz")
sha256sums=("e6a83dc50bc83a5ce6f20238da16fb941ab6090c419be8af8fc9223210f637fd")
license=("GPL")
-depends=("spl-utils-common>=0.7.1" "kmod" "linux-hardened=4.12.5.a-1")
+depends=("spl-utils-common>=0.7.1" "kmod" "linux-hardened=4.12.7.a-1")
build() {
cd "${srcdir}/spl-0.7.1"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.12.5-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.12.5-1-hardened/build \
+ --with-linux=/usr/lib/modules/4.12.7-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.12.7-1-hardened/build \
--with-config=kernel
make
}
@@ -52,10 +52,10 @@ package_spl-linux-hardened() {
package_spl-linux-hardened-headers() {
pkgdesc="Solaris Porting Layer kernel headers."
- conflicts=('spl-archiso-linux-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' )
+ conflicts=('spl-archiso-linux-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
cd "${srcdir}/spl-0.7.1"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.12.5-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.12.7-1-hardened/Module.symvers
}