summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesus Alvarez2018-03-16 20:54:06 -0700
committerJesus Alvarez2018-03-16 20:54:06 -0700
commit77df8f7b7320372618cd158b5cb957c3776c9f06 (patch)
treece1488a7a556f0d1928bc55c10c3ab9bd3c8f60f /PKGBUILD
parent58c7b55dfcb707c8fc9032b466355f6d9c656587 (diff)
downloadaur-77df8f7b7320372618cd158b5cb957c3776c9f06.tar.gz
Semi-automated update for 4.15.8.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 456ce0ae42f1..5fc496fb5b4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,22 +17,22 @@
pkgbase="spl-linux-vfio"
pkgname=("spl-linux-vfio" "spl-linux-vfio-headers")
-pkgver=0.7.6.4.15.2.1
+pkgver=0.7.6.4.15.8.1
pkgrel=1
-makedepends=("linux-vfio-headers=4.15.2-1" "git")
+makedepends=("linux-vfio-headers=4.15.8-1" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/spl-0.7.6.tar.gz")
sha256sums=("648148762969d1ee94290c494c4f022aeacabe0e84cddf65906af608be666f95")
license=("GPL")
-depends=("spl-utils-common=0.7.6" "kmod" "linux-vfio=4.15.2-1")
+depends=("spl-utils-common=0.7.6" "kmod" "linux-vfio=4.15.8-1")
build() {
cd "${srcdir}/spl-0.7.6"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.15.2-1-vfio/build \
- --with-linux-obj=/usr/lib/modules/4.15.2-1-vfio/build \
+ --with-linux=/usr/lib/modules/4.15.8-1-vfio/build \
+ --with-linux-obj=/usr/lib/modules/4.15.8-1-vfio/build \
--with-config=kernel
make
}
@@ -53,10 +53,10 @@ package_spl-linux-vfio() {
package_spl-linux-vfio-headers() {
pkgdesc="Solaris Porting Layer kernel headers."
- conflicts=('spl-archiso-linux-headers' 'spl-archiso-linux-git-headers' 'spl-linux-hardened-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-threadripper-headers' 'spl-linux-threadripper-git-headers' 'spl-linux-threadripper-vfio-headers' 'spl-linux-threadripper-vfio-git-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
+ conflicts=('spl-archiso-linux-headers' 'spl-archiso-linux-git-headers' 'spl-linux-hardened-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
cd "${srcdir}/spl-0.7.6"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.15.2-1-vfio/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.15.8-1-vfio/Module.symvers
}