summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesus Alvarez2015-07-03 10:45:20 -0700
committerJesus Alvarez2015-07-03 10:45:20 -0700
commit6aa749e44f6ddaf24e84fee9bf8fb9b0193f3aee (patch)
treeec253e880fad8284c6033af3c2bc064b74a9c36c /PKGBUILD
downloadaur-6aa749e44f6ddaf24e84fee9bf8fb9b0193f3aee.tar.gz
Update for kernel
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a77dbbf7ba20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
+# Contributor: Kyle Fuller <inbox at kylefuller dot co dot uk>
+#
+# This PKGBUILD was generated by the archzfs build scripts located at
+#
+# http://github.com/demizer/archzfs
+#
+# The build script generates and updates the pkgver and _kernel* variables.
+#
+pkgname="spl-utils-lts"
+pkgver=0.6.4.2_3.14.45_1
+pkgrel=2
+pkgdesc="Solaris Porting Layer kernel module support files."
+arch=("i686" "x86_64")
+url="http://zfsonlinux.org/"
+source=("http://archive.zfsonlinux.org/downloads/zfsonlinux/spl/spl-0.6.4.2.tar.gz"
+ "spl-utils.hostid")
+groups=("archzfs-lts")
+license=("GPL")
+provides=("spl-utils")
+conflicts=("spl-utils" "spl-utils-git")
+
+build() {
+ cd "${srcdir}/spl-0.6.4.2"
+ ./autogen.sh
+
+ _at_enable=""
+ [ "${CARCH}" == "i686" ] && _at_enable="--enable-atomic-spinlocks"
+
+ ./configure --prefix=/usr \
+ --libdir=/usr/lib \
+ --sbindir=/usr/bin \
+ --with-config=user \
+ ${_at_enable}
+
+ make
+}
+
+package() {
+ cd "${srcdir}/spl-0.6.4.2"
+ make DESTDIR="${pkgdir}" install
+
+ install -D -m644 "${srcdir}"/spl-utils.hostid "${pkgdir}"/etc/hostid
+}
+sha256sums=('a5ff33fbfc8dfa5b0a7508a511d1affde7bc69185515e7f09af45ed5ab0648ad'
+ 'ad95131bc0b799c0b1af477fb14fcf26a6a9f76079e48bf090acb7e8367bfd0e')