summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorL. Bradley LaBoon2016-01-15 18:25:37 -0500
committerL. Bradley LaBoon2016-01-15 18:25:37 -0500
commit59a4f997beb16bdb7c910094fe0e32177ca45e39 (patch)
treebeea11b39c9599805f28b7f795c4fe282af8e806 /PKGBUILD
parent61ac1a68d691268cdad05aaeb30dabbede9dde69 (diff)
downloadaur-59a4f997beb16bdb7c910094fe0e32177ca45e39.tar.gz
Updated PKGBUILD to use proper variables
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99419a6c7600..242bb09effcd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,21 +8,22 @@ arch=('x86_64' 'i686')
license=('custom')
conflicts=('splunk')
install="$pkgname.install"
-source=(
- "http://download.splunk.com/products/splunk/releases/6.3.2/universalforwarder/linux/$pkgname-${pkgver//_/-}-Linux-$CARCH.tgz"
+source_i686=(
+ "http://download.splunk.com/products/splunk/releases/6.3.2/universalforwarder/linux/$pkgname-${pkgver//_/-}-Linux-i686.tgz"
"$pkgname.service"
)
-if [ $CARCH == 'i686' ]; then
- sha256sums=(
- '7e38301cda465921f4eccc817fc5edcecdccf34961f6f8fb7fc2f2a2bcf06d41'
- '8bd6b2bcf9e9d89d3ab2160c409687313bbee00b7e44b3df3266b44d15a5c152'
- )
-else
- sha256sums=(
- 'cec2892f5501103203370c65f63953014a7618072e4ff34d053b526879642473'
- '8bd6b2bcf9e9d89d3ab2160c409687313bbee00b7e44b3df3266b44d15a5c152'
- )
-fi
+source_x86_64=(
+ "http://download.splunk.com/products/splunk/releases/6.3.2/universalforwarder/linux/$pkgname-${pkgver//_/-}-Linux-x86_64.tgz"
+ "$pkgname.service"
+)
+sha256sums_i686=(
+ '7e38301cda465921f4eccc817fc5edcecdccf34961f6f8fb7fc2f2a2bcf06d41'
+ '8bd6b2bcf9e9d89d3ab2160c409687313bbee00b7e44b3df3266b44d15a5c152'
+)
+sha256sums_x86_64=(
+ 'cec2892f5501103203370c65f63953014a7618072e4ff34d053b526879642473'
+ '8bd6b2bcf9e9d89d3ab2160c409687313bbee00b7e44b3df3266b44d15a5c152'
+)
package() {
cd "$srcdir"