summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Jost2015-07-15 12:01:13 +0200
committerThomas Jost2015-07-15 12:01:13 +0200
commit7ff43ee2d7726c335fefca6cc297bdf8d7ff74dc (patch)
treed52eabaae3bcb6a11f531f3981e06e518071345e /PKGBUILD
parent1634ef27e939484cf89f44085d86619e6224ee68 (diff)
downloadaur-7ff43ee2d7726c335fefca6cc297bdf8d7ff74dc.tar.gz
Fix dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 20 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e9e35fcbc00..04d4aff26ca4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,41 @@
-# Maintainer: Rasmus Steinke <rasi at xssn dot at>
-
+# Maintainer: Thomas Jost <schnouki@schnouki.net>
+# Contributor: Rasmus Steinke <rasi at xssn dot at>
pkgname=spop-git
_pkgname=spop
-pkgver=327.3890ab3
+pkgver=r328.1a26dec
pkgrel=1
pkgdesc="A Spotify client running as a daemon, similar to mpd."
arch=('i686' 'x86_64')
url='https://github.com/Schnouki/spop'
license=('GPL')
-depends=('libspotify')
+depends=('libspotify' 'json-glib')
makedepends=('git' 'cmake')
+optdepends=(
+ 'libao: libao audio output'
+ 'sox: libsox audio output'
+ 'dbus-glib: awesome integration'
+ 'libnotify: desktop notifications support'
+ 'libsoup: last.fm scrobble support'
+ 'python: dspop GUI'
+ 'dmenu: dspop GUI (or rofi)'
+ 'rofi: dspop GUI (or dmenu)'
+)
source=('git+https://github.com/Schnouki/spop.git')
+md5sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "${srcdir}/${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build () {
- cp -a ${_pkgname} ${_pkgname}-build
- cd ${_pkgname}-build
- cmake -DCMAKE_INSTALL_PREFIX:PATH=${pkgdir}/usr .
+ cd "${srcdir}/${_pkgname}"
+ cmake -DCMAKE_INSTALL_PREFIX:PATH="${pkgdir}/usr" .
make
}
package() {
- cd ${srcdir}/${_pkgname}-build
+ cd "${srcdir}/${_pkgname}"
make DEST="${pkgdir}" install
- install -D -m 644 ${srcdir}/${_pkgname-build}/spopd.conf.sample ${pkgdir}/usr/share/doc/spop/spopd.conf.sample
+ install -D -m 644 "${srcdir}/${_pkgname-build}"/spopd.conf.sample "${pkgdir}"/usr/share/doc/spop/spopd.conf.sample
}
-
-md5sums=('SKIP')