summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2021-09-10 02:10:25 +0200
committerDaniel Peukert2021-09-10 02:10:25 +0200
commitbf314710db20c3ab93320c86577997d2f0596f28 (patch)
tree123c0a905a1808dd315ee53601d565c74248be37 /PKGBUILD
parentbfccd96e886fffafaaddb1510dca3d6a15f793ca (diff)
downloadaur-bf314710db20c3ab93320c86577997d2f0596f28.tar.gz
Update spot-client to 0.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b136dcf849e9..711dbb3f2009 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,30 @@
# Maintainer: Daniel Peukert <daniel@peukert.cc>
+# Contributor: NicoHood <archlinux {cat} nicohood {dog} de>
_projectname='spot'
pkgname="$_projectname-client"
-pkgver='0.1.16'
+pkgver='0.2.0'
pkgrel='1'
pkgdesc='Gtk/Rust native Spotify client'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/xou816/$_projectname"
license=('MIT')
-depends=('alsa-lib' 'glib2' 'gtk3' 'libhandy' 'libpulse' 'openssl')
+depends=('alsa-lib' 'cairo' 'glib2' 'glibc' 'graphene' 'gtk4' 'libadwaita' 'libpulse' 'openssl' 'pango')
optdepends=('org.freedesktop.secrets')
makedepends=('cargo' 'meson>=0.50.0')
checkdepends=('appstream-glib')
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('da9ca8d1c29d8e88bac630e25a07c9682d61ebf8ac61db77ee50db3f4adc3a40')
+sha512sums=('04930c3be37b45ad9dcac3448d6e3154f597a3caa945fc22f82e552d46960ec869e67d43b7c8117e2ecc6e97e2bfd6d7d0a8a43926467d72c10a706bc137daf7')
+validpgpkeys=() # waiting for https://github.com/xou816/spot/issues/283
_sourcedirectory="$_projectname-$pkgver"
_builddirectory='build'
build() {
cd "$srcdir/"
+ # We're not using arch-meson, because upstream recommends using --buildtype 'release'
+ # The offline build flag is turned off, as we're not predownloading rust dependencies
meson setup --prefix '/usr' --libexecdir 'lib' --sbindir 'bin' --buildtype 'release' --wrap-mode 'nodownload' \
- -Db_lto='true' -Db_pie='true' -Doffline='false' -Dfeatures='warn-cache' "$_sourcedirectory" "$_builddirectory"
+ -Db_lto='true' -Db_pie='true' -Doffline='false' "$_sourcedirectory" "$_builddirectory"
meson compile -C "$_builddirectory"
}
@@ -31,6 +35,6 @@ check() {
package() {
cd "$srcdir/"
- DESTDIR="$pkgdir" meson install -C "$_builddirectory"
+ meson install -C "$_builddirectory" --destdir "$pkgdir"
install -Dm644 "$_sourcedirectory/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}