summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2021-08-17 23:23:48 +0200
committerDaniel Peukert2021-08-17 23:23:48 +0200
commitbfccd96e886fffafaaddb1510dca3d6a15f793ca (patch)
tree95670b05ec9363ef4c9d9a3f0325b692ff15014e /PKGBUILD
parenta66e905ac913c1eacdd3e49414b1b94822022d76 (diff)
downloadaur-bfccd96e886fffafaaddb1510dca3d6a15f793ca.tar.gz
Update spot-client to 0.1.16
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 4 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca2043234a39..b136dcf849e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Daniel Peukert <daniel@peukert.cc>
_projectname='spot'
pkgname="$_projectname-client"
-pkgver='0.1.15'
-pkgrel='2'
+pkgver='0.1.16'
+pkgrel='1'
pkgdesc='Gtk/Rust native Spotify client'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/xou816/$_projectname"
@@ -11,23 +11,12 @@ depends=('alsa-lib' 'glib2' 'gtk3' 'libhandy' 'libpulse' 'openssl')
optdepends=('org.freedesktop.secrets')
makedepends=('cargo' 'meson>=0.50.0')
checkdepends=('appstream-glib')
-source=(
- "$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
- 'disable-clippy-test.diff'
-)
-sha256sums=('55fa29d3627b8e6218b6a0f927391887fbb1a496b597a74a3af70b75207f4121'
- 'ebf64746a9fff1242bdbf47736c78aaf7c3c94ef6423002662dbbb74db685004')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('da9ca8d1c29d8e88bac630e25a07c9682d61ebf8ac61db77ee50db3f4adc3a40')
_sourcedirectory="$_projectname-$pkgver"
_builddirectory='build'
-prepare() {
- cd "$srcdir/$_sourcedirectory/"
- # Disable Clippy test for now, as it still complains about some errors not yet fixed by upstream
- # When reenabling, don't forget to use a patch to explicitly specify the Cargo.toml path (https://github.com/xou816/spot/issues/252#issuecomment-880941157)
- patch --forward -p1 < '../disable-clippy-test.diff'
-}
-
build() {
cd "$srcdir/"
meson setup --prefix '/usr' --libexecdir 'lib' --sbindir 'bin' --buildtype 'release' --wrap-mode 'nodownload' \