summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2022-03-08 12:08:50 +0100
committerDaniel Peukert2022-03-08 12:08:50 +0100
commitf8f951853547ecb3c99ea38694dca71d62060cc5 (patch)
tree3616169b9987a80f905f792166a3b6d2736b30a8 /PKGBUILD
parenteab9b3c628e3a374d93e6c68384197b3a8dc0830 (diff)
downloadaur-f8f951853547ecb3c99ea38694dca71d62060cc5.tar.gz
Disable clippy tests for spot-client
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 13 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30adf299a60a..d0d954295552 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,13 +12,24 @@ depends=('alsa-lib' 'cairo' 'glib2' 'glibc' 'graphene' 'gtk4' 'libadwaita' 'libp
optdepends=('org.freedesktop.secrets')
makedepends=('cargo' 'meson>=0.50.0')
checkdepends=('appstream-glib')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha512sums=('b0127dbe2a1430dcc288c9ef6bd61f0afa92e4ca6316d4e84c7e6bf7051cffc90a8778312e04991f91a2090728a7ce3e288249d1c8562106f7851dc701e97873')
+source=(
+ "$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
+ 'disable-clippy.patch'
+)
+sha512sums=('b0127dbe2a1430dcc288c9ef6bd61f0afa92e4ca6316d4e84c7e6bf7051cffc90a8778312e04991f91a2090728a7ce3e288249d1c8562106f7851dc701e97873'
+ '1cb0faced2e6801cb994e9af7b81411355837b2efcd9c82b82751508e0bfcc967c50b3d6296bfdb8c017bbf2e7a503a3920d36cb896e44c896c23f5b9e1d13f1')
validpgpkeys=() # waiting for https://github.com/xou816/spot/issues/283
_sourcedirectory="$_projectname-$pkgver"
_builddirectory='build'
+prepare() {
+ cd "$srcdir/$_sourcedirectory/"
+
+ # Disable clippy tests, as they don't realy make sense for user builds (https://gitlab.com/dpeukert/pkgbuilds/-/issues/37)
+ patch --forward -p1 < '../disable-clippy.patch'
+}
+
build() {
cd "$srcdir/"
# We're not using arch-meson, because upstream recommends using --buildtype 'release'