summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAshley Whetter2016-11-16 06:46:13 +0000
committerAshley Whetter2016-11-16 06:46:13 +0000
commitc3fd84340c87b6bf15dee2a853b3ed2c92448b03 (patch)
tree76b07561756063acb7e367a0730181978f3d2f10 /PKGBUILD
parent924a82bd20ee6606603c9381f964a36cc5ff8034 (diff)
downloadaur-c3fd84340c87b6bf15dee2a853b3ed2c92448b03.tar.gz
Added license file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f12ecb9f3c0c..1ce489607a66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=spotify
pkgver=1.0.42.151
_anotherpkgver=.g19de0aa6
-pkgrel=1
+pkgrel=2
pkgdesc="A proprietary music streaming service"
arch=('x86_64' 'i686')
license=('custom:"Copyright (c) 2006-2010 Spotify Ltd"')
@@ -12,15 +12,17 @@ url="http://www.spotify.com"
options=('!strip' '!upx')
source=('spotify'
-'spotify.protocol')
-md5sums=('cfef2f72647980c639201c6ab39e8534'
- 'ef25ddc5b6bf8fe1a0d64cbd79e1f7b4')
-md5sums_x86_64=('dcce36b6956fd12baff87427357558d2')
-md5sums_i686=('c2840db7c82747591f8ab480da1dcca0')
+'spotify.protocol'
+'LICENSE')
+sha256sums=('989920e9360cadc1a8103b8c04acf0c87cb7911eb9a09dddb0cf4708d6249d34'
+ 'af54f3b90cac46fa100b3f919a9225d10d847617d24aa9af3d832e7689f482c3'
+ '4e8bea31ca27e16cac9c9dcd8f6ec27e1f82b45de86d6fee7a1e77e23f884b92')
source_x86_64=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}-74_amd64.deb")
+sha256sums_x86_64=('905c0c87091855c9d5d354ebeca9fb3951ff60c08f0dfc1c1898bf66cc8acd15')
source_i686=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}-27_i386.deb")
+sha256sums_i686=('a7acb3929747e47669bdcb997c820101e79be3dd4dd48a3596873c5e03935a7c')
depends=("alsa-lib>=1.0.14" "gconf" "gtk2" "glib2" "nss" "libsystemd" "libxtst" "libx11" "libxss" "libcurl-compat" "desktop-file-utils" "rtmpdump")
optdepends=('ffmpeg0.10: Adds support for playback of local files'
@@ -48,4 +50,7 @@ package() {
# Copy protocol file for KDE
install -Dm644 "${srcdir}/spotify.protocol" "${pkgdir}/usr/share/kservices5/spotify.protocol"
+
+ # License
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}