diff options
author | Daniel M. Capella | 2016-11-09 17:14:06 -0500 |
---|---|---|
committer | Daniel M. Capella | 2016-11-09 17:14:06 -0500 |
commit | 9f30ae97e7aba723ac7b67d128bcf8a7c0c3eb36 (patch) | |
tree | 2ce81e729633b96ab35fb0d47643db566c39de14 /PKGBUILD | |
parent | 8494131d1368257b294ed3bca6266b5899a677c0 (diff) | |
download | aur-9f30ae97e7aba723ac7b67d128bcf8a7c0c3eb36.tar.gz |
Touch up
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 38 |
1 files changed, 24 insertions, 14 deletions
@@ -1,21 +1,31 @@ -# Maintainer: Sibren Vasse <arch @ sibrenvasse dot nl> +# Maintainer: Daniel M. Capella <polyzen@archlinux.info> +# Contributor: Sibren Vasse <arch @ sibrenvasse dot nl> # Contributor: Preston Carpenter <APragmaticPlace@gmail.com> -pkgname=spotify-adkiller -source=("spotify-adkiller::git+http://github.com/SecUpwN/Spotify-AdKiller#branch=master") -url="https://github.com/SecUpwN/Spotify-AdKiller" -pkgver=10 -pkgrel=2 -epoch=0 -pkgdesc="Your Party with Spotify - but without ads!" +pkgname=spotify-adkiller-git +pkgver=r155.1fa0ff9 +pkgrel=1 +pkgdesc='Your Party with Spotify - without ads!' arch=('any') -makedepends=('git') +url=https://github.com/SecUpwN/Spotify-AdKiller license=('GPL3') -depends=("xorg-xprop" "libpulse" "libnotify" "pulseaudio" "xdotool") -md5sums=('SKIP') +depends=('libnotify' 'pulseaudio' 'spotify' 'xdotool' 'xorg-xprop') +makedepends=('git') +provides=("${pkgname%-*}") +conflicts=("${pkgname%-*}") +source=("$url.git") +sha512sums=('SKIP') + +pkgver() { + cd ${pkgname%-*} + printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" +} package() { - install -Dm755 "$srcdir"/"$pkgname"/spotify-adkiller.sh "$pkgdir"/usr/bin/spotify-adkiller.sh - install -Dm755 "$srcdir"/"$pkgname"/spotify-wrapper.sh "$pkgdir"/usr/bin/spotify-wrapper.sh - install -Dm644 "$srcdir"/"$pkgname"/"Spotify (AdKiller).desktop" "$pkgdir"/usr/share/applications/"Spotify (AdKiller).desktop" + cd ${pkgname%-*} + install -Dm755 ${pkgname%-*}.sh "$pkgdir"/usr/bin/${pkgname%-*}.sh + install -Dm755 spotify-wrapper.sh "$pkgdir"/usr/bin/spotify-wrapper.sh + install -Dm644 'Spotify (AdKiller).desktop' "$pkgdir"/usr/share/applications/'Spotify (AdKiller).desktop' } + +# vim:set ts=2 sw=2 et: |