summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMicah Cowell2016-04-28 17:01:39 -0700
committerMicah Cowell2016-04-28 17:01:39 -0700
commit173df10b7db0e3bb5f5296e3abf05cda9f0a98cc (patch)
treea3131b8aa99f2fdc9dd463e071154213751aab7f /PKGBUILD
downloadaur-173df10b7db0e3bb5f5296e3abf05cda9f0a98cc.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..777ba55fa08e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: graysky <graysky AT archlinux DOT us>
+# Contributer: Serge Ziryukin <ftrvxmtrx@gmail.com>
+pkgname=spotify-now-git
+_pkgname=spotify-now
+pkgver=22.9443251
+pkgrel=1
+pkgdesc="Get information on the current Spotify song"
+arch=('any')
+url="https://github.com/getmicah/spotify-now"
+license=('MIT')
+makedepends=('git')
+conflicts=('spotify-now')
+source=("git://github.com/getmicah/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ echo "$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+package () {
+ cd "$_pkgname"
+ install -Dm755 $_pkgname "$pkgdir/usr/bin/$_pkgname"
+}