summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkraxarn2020-03-05 00:36:32 +0100
committerkraxarn2020-03-05 00:36:32 +0100
commit550bfe6ce23009995c79705af1cdb504e2b47a51 (patch)
treea85abba17d1fbd94ee728b0447cd7df3f513f31e /PKGBUILD
downloadaur-550bfe6ce23009995c79705af1cdb504e2b47a51.tar.gz
initial aur stuff
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6b6dc395ea8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: kraxarn <me@kraxarn.com>
+
+pkgname=spotify-qt
+pkgver=0.12
+pkgrel=1
+pkgdesc="Lightweight Spotify client using Qt"
+arch=(x86_64)
+url="https://github.com/kraxarn/spotify-qt"
+license=("GPL3")
+depends=(qt5-base)
+makedepends=(git cmake gcc make)
+source=("$url/archive/v${pkgver}.tar.gz")
+sha256sums=("0c99a7301b10386feeeb1b1c742b0028f0fa3433d9fb6865e55792961ad2dedb")
+
+build() {
+ cd "$pkgname-$pkgver"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr .
+ make $MAKEFLAGS
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ #cp spotify-qt "$pkgdir"/usr/bin
+ make DESTDIR="$pkgdir" install
+} \ No newline at end of file