summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavierCLL2018-02-25 12:28:50 -0500
committerXavierCLL2018-02-25 12:28:50 -0500
commit060347bd9c5824a8d322eb7bdd431d6bcf6d7a13 (patch)
treea71097d77d1289934b906b8389b70d387eb3f11a /PKGBUILD
parente9d2cf4235d6080df602d0f900306d2c2225118e (diff)
downloadaur-060347bd9c5824a8d322eb7bdd431d6bcf6d7a13.tar.gz
Fix deps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6c9cf6b548ee..6fd959cee8fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,26 @@
-_name=spotify-ripper
+# Maintainer: XavierCLL <xavier.corredor.llano (a) gmail.com>
+
pkgname=spotify-ripper
pkgver=2.11
-pkgrel=1
+pkgrel=2
pkgdesc='Command-line ripper for Spotify, with a workaround for playlist emptying'
arch=('any')
-url="https://github.com/SolidHal/$_name"
+url="c/$_name"
license=('MIT')
-depends=('python2' 'python2-pyspotify=2.0.5' 'python2-colorama-0.3.3' 'python2-mutagen-1.30' 'python2-requests>=2.3.0' 'python2-schedule>=0.3.1' 'python2-spotipy' 'lame')
+depends=('python2' 'mutagen' 'python2-pyspotify' 'python2-colorama' 'python2-requests' 'python2-schedule' 'python2-spotipy' 'lame')
optdepends=('flac: Rip songs to lossless FLAC encoding' 'opus-tools: Rip songs to Opus encoding' 'vorbis-tools: Rip songs to Ogg Vorbis encoding' 'faac: Rip songs to AAC format with FreeAAC' 'libav-git-no-libs: Rip songs to Apple Lossless format' 'fdkaac: Rip songs to MP4/M4A format with Fraunhofer FDK AAC codec')
makedepends=('python2-setuptools')
-source=("https://github.com/SolidHal/spotify-ripper/archive/"$pkgver".zip")
-md5sums=('9e15172c41c80eb46b149a3799f9e66a')
+source=("https://github.com/SolidHal/spotify-ripper/archive/$pkgver.zip"
+ "setup.py" "requirements.txt")
+md5sums=('9e15172c41c80eb46b149a3799f9e66a'
+ '2cc746f3bb1ed00e8bc7dc053829f5dc'
+ '433ec722cffccd32c7e31807262f1128')
package() {
- cd "$srcdir/$_name-$pkgver"
- python2 setup.py install --root="$pkgdir" --optimize=1 || return 1
+ # fix imports
+ cp setup.py $pkgname-$pkgver/
+ cp requirements.txt $pkgname-$pkgver/
+
+ cd "$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir"
}