summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRodrigo C. Gryzinski2019-12-10 10:34:25 -0300
committerRodrigo C. Gryzinski2019-12-10 10:34:25 -0300
commitbb6367e6ef3f115c33a127f69d267175f27fa4ac (patch)
tree9dbfb507fbfb3b66f0ec10e50d5906ab9fa7d643 /PKGBUILD
downloadaur-bb6367e6ef3f115c33a127f69d267175f27fa4ac.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba68e6ce1583
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Rodrigo Gryzinski <rogryza@gmail.com>
+
+pkgname='spotify-tui-bin'
+pkgver=v0.10.0
+pkgrel=1
+pkgdesc="Spotify client for the terminal written in Rust"
+arch=('x86_64')
+url='https://github.com/Rigellute/spotify-tui'
+license=('MIT')
+depends=(openssl libxcb)
+provides=('spotify-tui')
+
+source=("$url/releases/download/v$pkgver/spotify-tui-linux.tar.gz"
+ "https://raw.githubusercontent.com/Rigellute/spotify-tui/v$pkgver/LICENSE")
+sha256sums=('4fd5aca58b30766bc23fa0690652a683a9fb752a958267583a36d0c417328c67'
+ '76b2d30f74716c0cbd02e37868961dce2b52f65af6355864d010ee7e695d2b88')
+
+function package {
+ install -Dt "$pkgdir/usr/bin/" "$srcdir/spt"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}