summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Klink2017-07-14 22:38:55 +0200
committerFlorian Klink2017-07-14 22:38:55 +0200
commit4c7ba4eea110b2e16617f72151aff3d50f9488d0 (patch)
tree88e7beb4391ea3aabc158456b80ec3251bb628ff /PKGBUILD
parent3ceee80cfbc0c9bf6a933d1aff5427e5cd1247a3 (diff)
downloadaur-4c7ba4eea110b2e16617f72151aff3d50f9488d0.tar.gz
add post-tag commit counter in pkgver
Otherwise, packages on commits after v0.1.1 will still be called 0.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a664092c702..f50ab4841090 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Florian Klink <flokli@flokli.de>
pkgname=spotifyd
-pkgver=0.1.1
+pkgver=0.1.1.1.g60f111f
pkgrel=1
arch=('x86_64' 'armv7h')
depends=('pulseaudio' 'flac' 'libogg' 'libpulse' 'libsndfile' 'libvorbis')
@@ -15,7 +15,7 @@ sha256sums=('SKIP'
'67bce68cfad74bfccad4b471045d3c5d5fb0f693545f3ef12511d171ea41a5e4')
pkgver() {
cd $srcdir/spotifyd;
- echo $(git describe --tags --abbrev=0 --match 'v*' | sed 's/^v//')
+ git describe --tags --match 'v*' | sed 's/^v//;s/-/./g'
}
build() {