summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoodBoyNeon2024-06-09 10:48:54 +0545
committerGoodBoyNeon2024-06-09 10:48:54 +0545
commitc37d4cc2a2ea3976443ea7d2a601762210d6f0fa (patch)
treeaaee882973db23f4e2e2bb1747ee8925389f23e9 /PKGBUILD
downloadaur-c37d4cc2a2ea3976443ea7d2a601762210d6f0fa.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1f095e2106e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Sushant Ray <contact@neon.is-a.dev>
+
+pkgname='sprofile'
+pkgver=0.0.1
+pkgrel=1
+epoch=
+pkgdesc="A tool for accessing your spotify statistics without ever leaving the terminal"
+arch=('x86_64')
+url="https://github.com/goodboyneon/sprofile"
+license=('MIT')
+groups=()
+depends=('nodejs>=18' 'rust' 'cargo')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver.tar.gz::https://github.com/goodboyneon/$pkgname/archive/v$pkgver.tar.gz")
+noextract=()
+sha256sums=("d7c51b2d2de5fdb9153467386c55db89b070e2f6d27783805685c3ff796b565d")
+validpgpkeys=()
+
+# prepare() {
+# cd "$pkgname-$pkgver"
+# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
+# }
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cargo build --release
+}
+
+# check() {
+# cd "$pkgname-$pkgver"
+# make -k check
+# }
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}