summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMassimiliano Torromeo2012-04-02 18:24:56 +0200
committerMassimiliano Torromeo2012-04-02 18:24:56 +0200
commit8bd7894cbd3589ad61eea2651aea66d4b10be235 (patch)
tree7df9ccdd8d074acc47a4cdc555177698f7f2dfc2 /PKGBUILD
parentff9108a040c34653b920e8d079b6ed2479557b76 (diff)
downloadaur-8bd7894cbd3589ad61eea2651aea66d4b10be235.tar.gz
Split package/build and add python compile optimizations
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 985513311e03..afb8cae4fa27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
pkgname=sqlantaresia-git
-pkgver=20111003
+pkgver=20120402
pkgrel=1
pkgdesc="SQL Antaresia is a MySQL administrative tool aimed at developers and sysadmins"
arch=(any)
@@ -36,7 +36,11 @@ build() {
find . -type f -name .gitignore -delete
sh build.sh
- python2 setup.py install --root="$pkgdir"
+}
+
+package() {
+ cd "$srcdir/$_gitname-build/"
+ python2 setup.py install -O2 --root="$pkgdir"
install -m0644 -D "$srcdir/sqlantaresia.desktop" "$pkgdir/usr/share/applications/sqlantaresia.desktop"
install -D LICENSE "$pkgdir/usr/share/licenses/sqlantaresia/COPYING"
}