summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin Baxmann2021-05-27 14:08:41 +0200
committerKevin Baxmann2021-05-27 14:08:41 +0200
commit4244f271a07aa8f2ebfc89ff7b3f0bf89b1aca30 (patch)
treebdee625cd5239c8570a83daf3d3dcd85702cf86b /PKGBUILD
parent05a898efdd5e6ae0439626bc45cea3da1ee49a9c (diff)
downloadaur-4244f271a07aa8f2ebfc89ff7b3f0bf89b1aca30.tar.gz
Version bump, use direct download, add ext files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 5 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0c0726f1989..1212f901a067 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Previous Maintainer: Arne Hoch <arne@derhoch.de>
pkgname=sqlcl
-pkgver=20.2.0.174.1557
+pkgver=21.1.1.113.1704
pkgrel=1
pkgdesc="SQL Developer command line interface for Oracle"
arch=('i686' 'x86_64')
@@ -10,33 +10,21 @@ url="http://www.oracle.com/technetwork/developer-tools/sqlcl/overview/index.html
license=('custom:OTN')
depends=('java-runtime>=8')
-# Fail if retrieval is attempted of any of the manual:// URLs
-DLAGENTS+=('manual::/usr/bin/false');
-
source=("LICENSE"
- "manual://${pkgname}-${pkgver}.zip"
+ "https://download.oracle.com/otn_software/java/sqldeveloper/sqlcl-${pkgver}.zip"
"sqlcl.sh")
sha256sums=('f904a30b07ddf7806a33620f93b94c3d315154d26a371ece48695bb3555064a2'
- '5290a737c8e01b4296a704dcef1fe94abf960defc02bd24c272773bba9386b30'
+ 'ac31dc1bef29bbf972f35d000a4ef9669941038ff503655ac804e35df15e1dfc'
'4a0469c0adc964d91c611a643075087235dc2de8332e87297abe9865d19c2a14')
-msg "Warning: This software cannot be downloaded automatically."
-plain "You will need to sign up for an Oracle account and download the software from"
-plain "Oracle directly. Place the downloaded file in the same directory as the"
-plain "PKGBUILD and re-run makepkg."
-plain ""
-plain "The source .zip files can be downloaded from:"
-plain ""
-plain "https://www.oracle.com/technetwork/developer-tools/sqlcl/overview/index.html"
-plain ""
-plain ""
-
package() {
cd ${srcdir}
install -d ${pkgdir}/opt/${pkgname}/lib
install -d ${pkgdir}/opt/${pkgname}/bin
+ install -d ${pkgdir}/opt/${pkgname}/lib/ext
install -d ${pkgdir}/usr/bin
install -m 644 ${pkgname}/lib/*.jar ${pkgdir}/opt/${pkgname}/lib
+ install -m 644 ${pkgname}/lib/ext/*.jar ${pkgdir}/opt/${pkgname}/lib/ext
install -m 755 ${pkgname}/bin/sql ${pkgdir}/opt/${pkgname}/bin/sql
install -m 755 ${srcdir}/sqlcl.sh ${pkgdir}/usr/bin/sqlcl
}