summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVlad Pirlog2023-06-19 23:45:57 +0300
committerVlad Pirlog2023-06-19 23:45:57 +0300
commit59d02af4e844b09746ae562030a27d3f5086194b (patch)
tree8683d70d01d3190fa8f811c9f76654af967bac0d /PKGBUILD
parent9f54dc7adbae78e4c9ef7b001dea7b453a0d4565 (diff)
downloadaur-59d02af4e844b09746ae562030a27d3f5086194b.tar.gz
Update to 23.1.0.089.0929
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 20 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d80338e23767..20fa14007c24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,31 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: Vlad Pirlog <(firstname) at (lastname) dot net>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Kevin Baxmann <kvbx@kvbx.de>
# Contributor: Arne Hoch <arne@derhoch.de>
pkgname=sqlcl
-pkgver=22.2.0.172.1718
+pkgver='23.1.0.089.0929'
pkgrel=1
-pkgdesc="SQL Developer command line interface for Oracle"
+pkgdesc='SQL Developer command line interface for Oracle'
arch=('any')
-url="https://oracle.com/database/technologies/appdev/sqlcl.html"
+url='https://www.oracle.com/database/sqldeveloper/technologies/sqlcl'
license=('custom')
-depends=('java-runtime>=8')
+changelog=CHANGELOG.md
+depends=('bash' 'java-runtime>=8')
source=("$pkgname-$pkgver.zip::https://download.oracle.com/otn_software/java/sqldeveloper/$pkgname-$pkgver.zip"
- "$pkgname.sh"
- 'LICENSE')
-sha256sums=('eb69022227fec14578e319a398bd20958e94da77b263300ba09af8bd5aac4aa1'
- '34c5f2be48639dcd8ec9f38f950916a394ae399a0e583fbde4020acdccf951e0'
- '8f5642d74925ba3a4543c52b7a84b65c18aaa7dd3599c141e72ad5117e748929')
-
-PURGE_TARGETS=(*.exe *.txt)
+ "$pkgname.sh")
+sha256sums=('093f0d752bd9a497e168b7f3de4a3b68ea977bfe5948e2602ad91dd3a0147568'
+ '34c5f2be48639dcd8ec9f38f950916a394ae399a0e583fbde4020acdccf951e0')
package() {
- install -d "$pkgdir/opt/$pkgname/"
- cp -a --no-preserve=ownership,mode "$pkgname"/* "$pkgdir/opt/$pkgname/"
- install -D "$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm755 "$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+
+ install -Dm644 "$pkgname/bin/license.txt" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 "$pkgname/third-party-licenses.txt" -t "$pkgdir/usr/share/licenses/$pkgname/"
+
+ rm "$pkgname"/{README.md,Release-Notes.md,third-party-licenses.txt} \
+ "$pkgname"/bin/{license.txt,README.md,sql.exe}
+
+ install -d "$pkgdir/opt/$pkgname/"
+ cp -a --no-preserve=ownership,mode "$pkgname"/* "$pkgdir/opt/$pkgname/"
}