summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSammysHP2018-01-07 16:11:04 +0100
committerSammysHP2018-01-07 16:11:04 +0100
commit094371f996bb1c3d338aeeb6e59511765b195004 (patch)
tree00087e096b95174f3a99a3332d6dbfc3df0182f3 /PKGBUILD
downloadaur-094371f996bb1c3d338aeeb6e59511765b195004.tar.gz
Import from [community]
Package was removed from [community] at 2017-11-25.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47f8e5a50ea8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Geoffroy Carrier <geoffroy@archlinux.org>
+# Contributor: Roman Porizka <artee@beer.cz>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=sqliteman
+pkgver=1.2.2
+pkgrel=11
+pkgdesc="The best developer's and/or admin's GUI tool for Sqlite3 in the world"
+arch=('i686' 'x86_64')
+url="http://sqliteman.com/"
+license=('GPL')
+depends=('qscintilla-qt4')
+makedepends=('cmake')
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz" sqliteman-qscintilla-2.10.patch)
+md5sums=('5ecdf710e23606e1b924f740ea69306d'
+ '9922a1f404f2381564abfb9096973911')
+
+prepare() {
+ mkdir build
+
+# Fix qscintilla 2.10 detection
+ cd $pkgname-$pkgver
+ patch -p1 -i ../sqliteman-qscintilla-2.10.patch
+}
+
+build() {
+ cd build
+ cmake ../${pkgname}-${pkgver} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}