summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorblackhole2016-02-25 22:45:24 +0100
committerblackhole2016-02-25 22:45:24 +0100
commite3281917277ac9de9ab12ba107377496366c3a1c (patch)
tree9147b6cac7389186ff427e6802fb8b735d169519 /PKGBUILD
parentb6d7f20bcf70ddea7e27e9e6878c9a6693b1dad4 (diff)
downloadaur-e3281917277ac9de9ab12ba107377496366c3a1c.tar.gz
PKGBUILD fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 657fea298230..3e03450ae5e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,18 +5,19 @@
pkgname=squeezelite-r2-git
pkgver=v1.8.2.R2.r1.g681fc3d
-pkgrel=2
+pkgrel=3
pkgdesc='Lightweight headless squeezebox emulator - version r2'
arch=('i686' 'x86_64' 'armv6h')
url='http://www.marcoc1712.it/'
license=(GPL3)
depends=('alsa-lib')
-makedepends=('git' 'alsa-lib' 'faad2' 'flac' 'libmad' 'libvorbis' 'mpg123')
+makedepends=('git' 'alsa-lib' 'faad2' 'flac' 'libmad' 'libvorbis' 'mpg123' 'portaudio')
optdepends=('faad2: Support for decoding AAC'
'flac: Support for decoding FLAC'
'libmad: Support for decoding MP3'
'libvorbis: Support for decoding Ogg Vorbis'
- 'mpg123: Support for decoding MP3')
+ 'mpg123: Support for decoding MP3'
+ 'portaudio: Use of binary using portaudio for output')
provides=('squeezelite')
conflicts=('squeezelite')
source=('git+https://github.com/marcoc1712/squeezelite-R2')
@@ -30,6 +31,15 @@ pkgver() {
build() {
cd squeezelite-R2/
+ unset LDFLAGS
+ sed -i '/LDFLAGS/s|$| -lm -lasound|' Makefile.pa
+
+ # build squeezelite-pa
+ make -f Makefile.pa
+
+ # clean up
+ make clean
+
# build squeezelite
make