summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMax Ammann2015-12-21 21:52:37 +0100
committerMax Ammann2015-12-21 21:52:37 +0100
commit414bf92aa1ad267b88201b3e497bc76dfb7cc055 (patch)
treebd459df0e2ef05f08e92cc988ccb3b3f963b7a4d /PKGBUILD
downloadaur-414bf92aa1ad267b88201b3e497bc76dfb7cc055.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec6741395cec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Ammann Max <maximilian.ammann@googlemail.com>
+pkgname=srmio
+pkgver=0.1.1~git1
+pkgrel=1
+pkgdesc="library + command line tools to access a \"Schoberer Rad Messtechnik\" PowerControl V, VI and 7 + read/write their files"
+arch=('i686' 'x86_64')
+url="http://www.zuto.de/project/srmio/"
+license=('custom: Rainer Clasen')
+makedepends=('gcc' 'make')
+depends=()
+options=('!strip' '!buildflags' 'staticlibs')
+source=(http://www.zuto.de/project/files/srmio/srmio-0.1.1~git1.tar.gz)
+md5sums=(badca33309f469930e13a7d40ea6eadf)
+
+build() {
+ cd "${srcdir}/srmio-$pkgver/"
+ ./configure
+ make -j8
+}
+
+package() {
+ cd "${srcdir}/srmio-$pkgver/"
+ make DESTDIR="$pkgdir/" install
+}