summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Prager2024-01-02 00:46:45 +0100
committerMichael Prager2024-01-02 00:46:45 +0100
commit4abee584d22f08d7622bb55e782ea2b6466df275 (patch)
tree042e128de1a144cda55ab980720f6a12d6bff0f8 /PKGBUILD
parent2525819fea921973a0264d987853136a7336f246 (diff)
downloadaur-4abee584d22f08d7622bb55e782ea2b6466df275.tar.gz
Fixed package no longer being available on author's website. Use github package instead. This needed some additional workarounds since the packages differ
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2a6a44eed94..ac9895a73966 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ammann Max <maximilian.ammann@googlemail.com>
pkgname=srmio
pkgver=0.1.1~git1
-pkgrel=1
+pkgrel=2
pkgdesc="library + command line tools to access a \"Schoberer Rad Messtechnik\" PowerControl V, VI and 7 + read/write their files"
arch=('i686' 'x86_64')
url="http://www.zuto.de/project/srmio/"
@@ -9,16 +9,23 @@ license=('custom: Rainer Clasen')
makedepends=('gcc' 'make')
depends=()
options=('!strip' '!buildflags' 'staticlibs')
-source=(http://www.zuto.de/project/files/srmio/srmio-0.1.1~git1.tar.gz)
-md5sums=(badca33309f469930e13a7d40ea6eadf)
+source=(https://github.com/rclasen/srmio/archive/refs/tags/v0.1.1git1.tar.gz)
+md5sums=('09aaa574e130431b1b943329e9029ff0')
+pkgverstripped=$(echo $pkgver | sed -r 's/~//g')
build() {
- cd "${srcdir}/srmio-$pkgver/"
+ cd "${srcdir}/srmio-$pkgverstripped/"
+
+ # resurrect a variable that would have been generated by a now obsolete autoconf macro. Noweverdays this is simply always true.
+ export ac_cv_header_time=yes
+ # package on github does not ship with pre-generated configuration in contrast to the pacakge that was available on zuto.de
+ sh ./genautomake.sh
+
./configure --prefix=/usr/
make -j8
}
package() {
- cd "${srcdir}/srmio-$pkgver/"
+ cd "${srcdir}/srmio-$pkgverstripped/"
make DESTDIR="$pkgdir/" install
}