summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Bundy2019-02-13 09:20:34 -0800
committerChristian Bundy2019-02-13 09:20:34 -0800
commit445c40c25afc616462f3a4017435e45bd1475a7b (patch)
tree5defc7a58eb6c2bb9f408a8085df3adfeee02e5d /PKGBUILD
parentd73ca25c95e312c24b23afdf7bbda36660efebaa (diff)
downloadaur-445c40c25afc616462f3a4017435e45bd1475a7b.tar.gz
Depend on electron2, only build once
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80a25231a26e..095b150be416 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=ssb-patchwork-git
_srcname=patchwork
_aurname=ssb-patchwork
-pkgver=3.10.1.r13.g72852e6b
-pkgrel=3
+pkgver=3.10.1.r301.g9750bc4d
+pkgrel=1
pkgdesc="A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)"
arch=('i686' 'x86_64')
url="https://github.com/ssbc/patchwork"
license=('AGPL3')
-depends=('libxtst' 'libxext' 'libxkbfile' 'gconf' 'libsodium' 'libxss' 'gtk2' 'alsa-lib' 'nss' 'electron')
+depends=('libxtst' 'libxext' 'libxkbfile' 'gconf' 'libsodium' 'libxss' 'gtk2' 'alsa-lib' 'nss' 'electron2')
makedepends=('nodejs' 'npm')
provides=("ssb-patchwork=${pkgver}")
conflicts=('ssb-patchwork')
@@ -36,8 +36,19 @@ pkgver() {
build() {
cd "${srcdir}/${_srcname}"
- npm ci --only=production
- npm run rebuild
+ # Electron's version.
+ export npm_config_target=$(electron2 -v)
+ # The architecture of Electron, can be ia32 or x64.
+ export npm_config_arch=x64
+ export npm_config_target_arch=x64
+ # Download headers for Electron.
+ export npm_config_disturl=https://atom.io/download/electron
+ # Tell node-pre-gyp that we are building for Electron.
+ export npm_config_runtime=electron
+ # Tell node-pre-gyp to build module from source code.
+ export npm_config_build_from_source=true
+
+ npm install --only=production
}
package() {