summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Bundy2018-07-24 19:12:47 -0700
committerChristian Bundy2018-07-24 19:14:30 -0700
commit69ed3a238ffbdc7d3a037b9c7c17191a313f1d93 (patch)
tree64d8b505dbcdc4ecad5d55b2349785226e5195fd /PKGBUILD
parent239d6bd08f79d5d8a8cc85a8896f0fb38f76a381 (diff)
downloadaur-69ed3a238ffbdc7d3a037b9c7c17191a313f1d93.tar.gz
Transition to ssb-patchwork-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 31 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 391c1a3a5096..64b87057b2b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Ryan Pepper <pypper@protonmail.com>
-# Maintainer: Daniel Landau <daniel@landau.fi>
+# Maintainer: Christian Bundy <christianbundy@fraction.io>
-pkgname=ssb-patchwork
-_upstream=patchwork
-pkgver=3.10.1
+pkgname=ssb-patchwork-git
+_srcname=patchwork
+_aurname=ssb-patchwork
+pkgver=3.10.1.r2.gf6309ea8
pkgrel=1
pkgdesc="A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)"
arch=('i686' 'x86_64')
@@ -11,28 +11,41 @@ url="https://github.com/ssbc/patchwork"
license=('AGPL3')
depends=('libxtst' 'libxext' 'libxkbfile' 'gconf' 'libsodium' 'libxss' 'gtk2' 'alsa-lib' 'nss')
makedepends=('nodejs' 'npm')
+provides=("ssb-patchwork=${pkgver}")
+conflicts=('ssb-patchwork')
options=(!strip)
source=(
-"https://github.com/ssbc/${_upstream}/archive/v${pkgver}.tar.gz"
+"git+https://github.com/ssbc/${_srcname}.git"
'run.sh'
-"${pkgname}.desktop"
+"${_aurname}.desktop"
)
-md5sums=('8ecdb2794979e8fbc2b17f7818e44b33'
- 'bb315f14e6d7ef57976c8934ddad4fd9'
- '3c73b5245f2da7dd2e31729e2b57ad37')
+
+sha512sums=(
+'SKIP'
+'bbcd812b57fbef59993db18e7ac650013afe671846f7ea7b4908e7e664508a034851b336de2593dad11d871e803e55548896d55468339d91d4d4023ea2fe3b08'
+'09292ec2f7c02d741cbeb046bd99293f4d144314d0233252dd34a619e1aacbbbf28078677c0871d367240e29aa50d9197bbe0a35e5b14f7ff9a6288c386124f6'
+)
+
+pkgver() {
+ cd "${_srcname}"
+
+ # https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=linux-git&id=e03e86d03543561336930472671ffa3e8b8e8cbd#n34
+ git describe --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g;s/\.rc/rc/'
+}
+
build() {
- cd "${srcdir}/${_upstream}-${pkgver}"
+ cd "${srcdir}/${_srcname}"
npm ci
}
package() {
- cd "${srcdir}/${_upstream}-${pkgver}"
- install -d "${pkgdir}/opt/${pkgname}"
- cp -a * "${pkgdir}/opt/${pkgname}"
- install -D assets/icon.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/${pkgname}.png"
-
cd "${srcdir}"
- install -D run.sh "${pkgdir}/usr/bin/${pkgname}"
- install -D "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D run.sh "${pkgdir}/usr/bin/${_aurname}"
+ install -D "${_aurname}.desktop" "${pkgdir}/usr/share/applications/${_aurname}.desktop"
+
+ cd "${_srcname}"
+ install -d "${pkgdir}/opt/${_aurname}"
+ cp -a * "${pkgdir}/opt/${_aurname}"
+ install -D assets/icon.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/${_aurname}.png"
}