summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorspider-mario2018-10-13 13:44:32 +0200
committerspider-mario2018-10-13 13:44:32 +0200
commitba0f41b116759a7c78dd56d57b6beeaeac847e0c (patch)
treeaaf0431c1c273d9b4f5c44ef5c9735c10cb53c4f /PKGBUILD
downloadaur-ba0f41b116759a7c78dd56d57b6beeaeac847e0c.tar.gz
First version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93bfb7ea1306
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: spider-mario <spidermario@free.fr>
+pkgname=ssimulacra
+pkgver=0.1
+pkgrel=1
+pkgdesc="Structural SIMilarity Unveiling Local And Compression Related Artifacts"
+arch=('x86_64')
+url="https://github.com/cloudinary/ssimulacra"
+license=('Apache')
+depends=('opencv')
+makedepends=('vtk')
+source=('git+https://github.com/cloudinary/ssimulacra.git')
+sha512sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+ perl -pe 's/(?:C|LD)FLAGS\K=/+=/g' -i Makefile
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 ssimulacra "$pkgdir"/usr/bin/ssimulacra
+}