summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilliam J. Bowman2017-01-07 13:08:14 -0500
committerWilliam J. Bowman2017-01-07 13:08:14 -0500
commit0c5fb47491b28a87878cdf0bbe5de7dc82d4ebe6 (patch)
tree5a223411ad0f9322fe9f7a6b09e0dc076099435d /PKGBUILD
parent73ef612e6a292be00c5216e35a30339a9dfe60bf (diff)
downloadaur-0c5fb47491b28a87878cdf0bbe5de7dc82d4ebe6.tar.gz
Update to 1.6.1-1
* Update version * Update Coq dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d33002319af4..4ad9a320fc93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: William J. Bowman <aur@williamjbowman.com>
-# via Contributer pmates:
+# via Contributer pmates:
# For users having problems installing this, I recommend rebuilding several of the dependencies using the following modifications:
# - when building camlp5-transitional add "options=('staticlibs')" to the PKGBUILD file
# - when building coq edit the PKGBUILD file to use the 'usecamlp5' flag instead of 'usecamlp4'
-# - when building ssreflect modify the download location, as mentioned by daoo, and if you have coq 8.4pl4-1 you will have to remove the coq>=8.4 dependency since makepkg gets confused.
+# - when building ssreflect modify the download location, as mentioned by daoo, and if you have coq 8.4pl4-1 you will have to remove the coq>=8.4 dependency since makepkg gets confused.
pkgname=ssreflect
-pkgver=1.6
+pkgver=1.6.1
pkgrel=1
pkgdesc="A set of extensions to the scripting language of Coq."
url="https://math-comp.github.io/math-comp/"
arch=('i686' 'x86_64')
license=('GPL')
-depends=('coq=8.5') # Also works with 8.4pl6 but don't quite know how to say that
+depends=('coq>=8.5') # Works with 8.4pl6, 8.5pl3, and 8.6.0 but don't quite know how to say that
makedepends=('camlp5-transitional>=6.12')
source=(mathcomp-$pkgver.tar.gz::https://github.com/math-comp/math-comp/tarball/mathcomp-$pkgver)
-sha256sums=('19c5b5b872f50f8b055b86ea3d42692549813b0ebf1ebc6cfa1f05c8892a1bea')
-sha512sums=('b98e82fc39f44c2c885b739a1693c403278912703910efb54bca27096581074b5e11742a41e48b4923b515b549c3290a26b1d43b8dae0c2b56f85d40f56f5a4b')
+sha256sums=('b36883f87bcfdf6e9bfd4ded69c4a1215ff93b0421fabae8c852ccba15043801')
+sha512sums=('bdafa1445483e5028796e9e9a0c63ecd248f3ac385e3003403f5749fb6454bed2084e75f1982a474f17d7f45ca4a4894ee9f7a4cd708d1fa980639f2e4c1e548')
build() {
- cd $srcdir/math-comp-math-comp-52a8679/mathcomp/$pkgname
+ cd $srcdir/math-comp-math-comp-*/mathcomp/$pkgname
# SSReflect requires *a lot* of memory to build. It can be a good
# idea add -j1 to the following command to force a sequential build.
@@ -28,7 +28,6 @@ build() {
}
package(){
- cd $srcdir/math-comp-math-comp-52a8679/mathcomp/$pkgname
+ cd $srcdir/math-comp-math-comp-*/mathcomp/$pkgname
make DSTROOT=$pkgdir 'COQLIB:=$(DESTDIR)/$(shell coqtop -where)/' install
}
-