summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXuanrui Qi2019-07-07 03:29:42 -0700
committerXuanrui Qi2019-07-07 03:29:42 -0700
commitcfa080db80410ccb982d5ae6a206ad61679eefac (patch)
treed16906832c1559e909cf66375bc0e31325c2fa12 /PKGBUILD
downloadaur-cfa080db80410ccb982d5ae6a206ad61679eefac.tar.gz
First version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d1f6a87c567
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Xuanrui Qi <me@xuanruiqi.com>
+pkgname=ssrmint-git
+pkgver=r8.66e2482
+pkgrel=1
+pkgdesc="Ad-hoc pygments style and lexer for LaTeX pretty-printing of SSReflect"
+arch=('any')
+url="https://github.com/affeldt-aist/ssrmint"
+license=('BSD')
+depends=('python' 'python-pygments')
+makedepends=('git' 'python-setuptools')
+optdepends=()
+conflicts=()
+source=("$pkgname::git+https://github.com/affeldt-aist/ssrmint")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+
+# vim:set ts=2 sw=2 et: