summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormar77i2015-06-25 10:50:01 +0200
committermar77i2015-06-25 10:50:01 +0200
commit0df21d831f3d16cf15fcb07b55c962e88fc85143 (patch)
treed0f5349fd01359841d96dfab10e9bc6bb07d7378 /PKGBUILD
parent27aad93a2f5635d9ce9cebbf61b6947f90712151 (diff)
downloadaur-0df21d831f3d16cf15fcb07b55c962e88fc85143.tar.gz
automatically apply patches in source array
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b68e76f13b11..92713c4d2e4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,8 +25,8 @@ pkgver() {
}
prepare() {
+ local file
cd "${srcdir}/${_pkgname}"
- patch -p1 -i ../scrollback.patch # http://st.suckless.org/patches/st-scrollback.diff
sed \
-e '/char font/s/= .*/= "Fixed:pixelsize=13:style=SemiCondensed";/' \
-e '/char worddelimiters/s/= .*/= " '"'"'`\\\"()[]{}<>|";/' \
@@ -39,6 +39,13 @@ prepare() {
-e 's/_BSD_SOURCE/_DEFAULT_SOURCE/' \
-i config.mk
sed '/@tic/d' -i Makefile
+ for file in "${source[@]}"; do
+ if [[ "$file" != *.diff ]]; then
+ continue
+ fi
+ # add all patches present in source array
+ patch -Np1 <"$SRCDEST/$file"
+ done
}
build() {