summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormar77i2015-06-25 10:43:54 +0200
committermar77i2015-06-25 10:43:54 +0200
commit7f2c13ce77da5daacac06066666dcdd73e5aac7c (patch)
treef1028804b8f8f6863237f1cecd559fe927dab230 /PKGBUILD
parentd24ea821b52ab30087241873c32001f64cbbd76d (diff)
downloadaur-7f2c13ce77da5daacac06066666dcdd73e5aac7c.tar.gz
move tic invocation from Makefile to package()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ff5e10ca18e6..fc9cf60da50d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,6 +32,7 @@ prepare() {
-e '/char worddelimiters/s/= .*/= " '"'"'`\\\"()[]{}<>|";/' \
-e '/int defaultcs/s/= .*/= 1;/' \
-i config.def.h
+ sed '/@tic/d' -i Makefile
}
build() {
@@ -41,9 +42,8 @@ build() {
package() {
cd "${srcdir}/${_pkgname}"
- export TERMINFO="${pkgdir}/usr/share/terminfo"
- install -d "$TERMINFO"
make PREFIX=/usr DESTDIR="${pkgdir}" install
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 README "${pkgdir}/usr/share/doc/${pkgname}/README"
+ tic -s -o "${pkgdir}/usr/share/terminfo" st.info
}