summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSirPatrickCZ2018-08-03 12:48:30 +0200
committerSirPatrickCZ2018-08-03 12:48:30 +0200
commit1e34508e84b210cc69fea69c2522dc76ff18e9f3 (patch)
tree2ba36105e606de726389ba6f22bc94010c18478c /PKGBUILD
downloadaur-1e34508e84b210cc69fea69c2522dc76ff18e9f3.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..394523f0e293
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: SirPatrickCZ Fiala456@gmail.com
+pkgname="st-spcz-git"
+_pkgname="st"
+pkgver=0.8.1.r0.g8936abb
+pkgrel=1
+pkgdesc="Simple terminal emulator by suckless.org with mouse-scroll and alpha patches."
+arch=('x86_64')
+url="https://github.com/SirPatrickCZ/st"
+license=('MIT')
+options=('zipman')
+depends=('libxft')
+makedepends=('git' 'libxext' 'ncurses')
+optdepends=('xorg-fonts-misc')
+conflicts=('st')
+source=("st::git+https://github.com/SirPatrickCZ/st.git#branch=master")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${_pkgname}"
+ # skip terminfo which conflicts with nsurses
+ sed -i '/tic /,+1d' Makefile
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make PREFIX=/usr DESTDIR="${pkgdir}" TERMINFO="$pkgdir/usr/share/terminfo" install
+} \ No newline at end of file