summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Reiser2018-10-20 09:38:27 +0200
committerSimon Reiser2018-10-20 09:38:27 +0200
commit49b97cea5d727eb35e725bc5f9c016bcab4ef42f (patch)
tree4a9f329cab216a3a06f5a47885a889315e209875 /PKGBUILD
parent07462aab067f6e5f7ed2189044f39cf69701f845 (diff)
downloadaur-49b97cea5d727eb35e725bc5f9c016bcab4ef42f.tar.gz
v1.9.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d45f04589f92..7750d5974f43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: <simonfxr@gmail.com>
pkgname=stack-static
-pkgver=1.7.1
+pkgver=1.9.1
pkgrel=1
pkgdesc="The Haskell Tool Stack (linked statically)"
arch=('x86_64')
@@ -12,18 +12,18 @@ replaces=( stack stack-bin haskell-stack )
depends=( gmp gcc-libs zlib ncurses5-compat-libs ) # needed for working ghc downloaded by stack
optdepends=( bash-completion )
source=(
- "stack.bash"
- "https://github.com/commercialhaskell/stack/releases/download/v${pkgver}/stack-${pkgver}-linux-x86_64.tar.gz"
- "https://github.com/commercialhaskell/stack/releases/download/v${pkgver}/stack-${pkgver}-linux-x86_64.tar.gz.asc"
+ "stack.bash"
+ "https://github.com/commercialhaskell/stack/releases/download/v${pkgver}/stack-${pkgver}-linux-x86_64-static.tar.gz"
+ "https://github.com/commercialhaskell/stack/releases/download/v${pkgver}/stack-${pkgver}-linux-x86_64-static.tar.gz.asc"
)
sha256sums=('df46833a748574d01f38d4120e5021ee6fac9b8a70995674ca0bd2cacbd3e3c2'
- '647306bbf65dd0b555486e2a32776ba1cfe0c8f380e31c6aa93abd452cb209ee'
+ '332e5d0421e7a1afc96985050d985c0d2ba651f91dc2565faa5abfdef9d2a095'
'SKIP')
validpgpkeys=('C5705533DA4F78D8664B5DC0575159689BEFB442')
package() {
cd "${srcdir}"
- local d="stack-${pkgver}-linux-x86_64"
+ local d="stack-${pkgver}-linux-x86_64-static"
mkdir -p "${pkgdir}"/usr/{{bin,share/{doc,licenses}/"${pkgname}"},share/bash-completion/completions}
cp "${d}/stack" "${pkgdir}/usr/bin"
cp -R "${d}/doc/." "${pkgdir}/usr/share/doc/${pkgname}/"