summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Reiser2020-08-16 14:56:15 +0200
committerSimon Reiser2020-08-16 14:56:15 +0200
commit858836dee5ee895d7f09df23620561a4cf2f9945 (patch)
tree324dd8c4a1647faaf8daa68ad62b99af0db2c17c /PKGBUILD
parent792e988469d43086f3a8b7b7940966abd2479a22 (diff)
downloadaur-858836dee5ee895d7f09df23620561a4cf2f9945.tar.gz
v2.3.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 34dcfc099479..80b4daf51bd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_arch=$(uname -m)
pkgname=stack-static
-pkgver=2.3.1
+pkgver=2.3.3
pkgrel=1
pkgdesc="The Haskell Tool Stack (linked statically)"
arch=('x86_64')
@@ -18,17 +18,17 @@ optdepends=(
)
source=(
"stack.bash"
- "https://github.com/commercialhaskell/stack/releases/download/v${pkgver}/stack-${pkgver}-linux-x86_64-static.tar.gz"
- "https://github.com/commercialhaskell/stack/releases/download/v${pkgver}/stack-${pkgver}-linux-x86_64-static.tar.gz.asc"
+ "https://github.com/commercialhaskell/stack/releases/download/v${pkgver}/stack-${pkgver}-linux-x86_64.tar.gz"
+ "https://github.com/commercialhaskell/stack/releases/download/v${pkgver}/stack-${pkgver}-linux-x86_64.tar.gz.asc"
)
sha256sums=('df46833a748574d01f38d4120e5021ee6fac9b8a70995674ca0bd2cacbd3e3c2'
- '4bae8830b2614dddf3638a6d1a7bbbc3a5a833d05b2128eae37467841ac30e47'
+ 'e7329c75d9c7ea168eb12caa954102e451906f350604a18d6e852ac81da5a2be'
'SKIP')
validpgpkeys=('2C6A674E85EE3FB896AFC9B965101FF31C5C154D')
package() {
cd "${srcdir}"
- local d="stack-${pkgver}-linux-x86_64-static"
+ local d="stack-${pkgver}-linux-x86_64"
mkdir -p "${pkgdir}"/usr/{{bin,share/{doc,licenses}/"${pkgname}"},share/bash-completion/completions}
cp "${d}/stack" "${pkgdir}/usr/bin"
cp -R "${d}/doc/." "${pkgdir}/usr/share/doc/${pkgname}/"