summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMGislv2022-02-03 22:15:12 +0100
committerMGislv2022-02-03 22:15:12 +0100
commitea9b90e1aa012c8768dbca48cca0229644bc927a (patch)
treed9c20cbc7babd8f53d812feb270c9a41a121499e /PKGBUILD
parent3eb4dbb3f788b0c09e681f2c44c8c2ff0900e32e (diff)
downloadaur-ea9b90e1aa012c8768dbca48cca0229644bc927a.tar.gz
Fix crash (maybe)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 84c7732cc32d..d10a13d7d1e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,41 @@
-# Maintainer: MGislv <nocentinigabriele91@gmail.com>
+# Maintainer: MGislv <mgislv at ceppo.xyz>
# Contributor: mutantmonkey <aur@mutantmonkey.in>
pkgname=stag-git
pkgver=v1.0.r1.g0a158e7
-pkgrel=1
-pkgdesc="A public domain ncurses based audio file tagger"
+pkgrel=2
+pkgdesc='Ncurses based audio file tagger'
arch=('i686' 'x86_64')
-url="https://github.com/smabie/stag"
+url='https://github.com/smabie/stag'
license=('custom')
depends=('ncurses' 'taglib')
makedepends=('git')
conflicts=('stag')
-source=(git+https://github.com/smabie/stag)
-sha256sums=('SKIP')
+source=("git+$url.git"
+ 'libs.patch')
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
cd stag
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd stag
+ patch --forward --strip=1 --input="$srcdir"/libs.patch
+}
+
build() {
cd stag
sed -n '/Released into the public domain/p' README > LICENSE
- export CFLAGS="$CFLAGS -ansi -pedantic -Wall -D_DEFAULT_SOURCE"
- export LDFLAGS="${LDFLAGS/--as-needed,/} -L/usr/lib `taglib-config --libs` -ltag_c -lstdc++"
- export CPPFLAGS="-I/usr/include `taglib-config --cflags`"
+ export LDFLAGS="${LDFLAGS/--as-needed,/}"
make
}
package() {
cd stag
- install -Dm755 stag "$pkgdir"/usr/bin/stag
- install -Dm644 stag.1 "$pkgdir"/usr/share/man/man1/stag.1
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/stag/LICENSE
+ install -Dm755 stag "$pkgdir/usr/bin/stag"
+ install -Dm644 stag.1 "$pkgdir/usr/share/man/man1/stag.1"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}