summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12020-09-02 11:15:43 +0800
committerChocobo12020-09-02 11:17:04 +0800
commit426e2e07a5f806f8c512e50d10dc0f5bceae3124 (patch)
treeffbc3e3561483423bff673d0e6a8789c666a215d /PKGBUILD
downloadaur-426e2e07a5f806f8c512e50d10dc0f5bceae3124.tar.gz
newpkg: stalld-git r32.gabe5fe5-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31ddd4a66280
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=stalld-git
+pkgver=r32.gabe5fe5
+pkgrel=1
+pkgdesc="A daemon to prevent the starvation of operating system threads"
+arch=('i686' 'x86_64')
+url="https://git.kernel.org/pub/scm/utils/stalld/stalld.git/"
+license=('GPL2')
+depends=('glibc')
+makedepends=('git')
+provides=('stalld')
+conflicts=('stalld')
+source=("git+https://git.kernel.org/pub/scm/utils/stalld/stalld.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "stalld"
+
+ _rev=$(git rev-list --count --all)
+ _hash=$(git rev-parse --short HEAD)
+ printf "r%s.g%s" "$_rev" "$_hash"
+}
+
+build() {
+ cd "stalld"
+
+ make
+}
+
+package() {
+ cd "stalld"
+
+ make DESTDIR="$pkgdir" install
+}