summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMallchad2021-09-23 18:34:39 +0100
committerMallchad2021-09-23 18:34:39 +0100
commitb46a2595ecca1789ec6b6af1d524de0cfeb3320c (patch)
tree4f799e7efbcee857ff73cb088a92de66bc2e50e7 /PKGBUILD
parent686c43498c91d934c5744a67de221f913bea41a1 (diff)
downloadaur-b46a2595ecca1789ec6b6af1d524de0cfeb3320c.tar.gz
Patch 'CMakeLists.txt' to statically link the whole binary
This was how it was before it recently got changed and was reported as broken by an AUR comment (found incidentally by me too). The issue was simply not being able to find 'libstandardese.so' and 'libcppast.so' when running the executable. The change seems to somewhat of an issue upstream and is largely redundant and I specutlate might not be worth the effort until the situation is improved upstream. As far as I can tell, there is few if any projects that use the 'libstandardese.so', and if they do, they should need the headers anyway, which isn't provided by the 'make install', and it might be out of the scope of the PKGBUILD to do such a thing unless there is a good reason for it, considering any user would need to go upstream to get their headers until then even if it were attempted to be fixed. Also 'libcppast.so' is required but its a niche project and really has no reason yet to be a shared library. Considering the above it makes sense to just link it together. Bumped the 'pkgrel' to indicate this change that should be a fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a6e96084180..066bf39d4d5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=standardese-git
pkgver=0.5.2.r9.gefbc112
-pkgrel=3
+pkgrel=4
pkgdesc="A (work-in-progress) nextgen Doxygen for C++"
arch=('i686' 'x86_64')
url="https://github.com/foonathan/standardese"
@@ -19,6 +19,12 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ # Set to statically link dependencies
+ sed -i "/option(BUILD_SHARED_LIBS/d" "CMakeLists.txt"
+}
+
build() {
cd "$srcdir/${pkgname%-git}"
rm -rf build